What are the system requirements for DDO?

Follow

DDO System Requirements

Minimum Compatible System Requirements*
Operating System: Windows Vista (Service Pack 2 is recommended)
Processor (CPU): Intel Pentium 4 - 1.6GHz or AMD equivalent (with SSE support)
System RAM Memory: 1 GB
Graphics Card: 64MB Hardware Transform & Lighting (T&L) compatible
Internet Connection: Broadband Internet Connection
DirectX Version: DirectX 9.0c
Disk Space: 11 GB

* Note: Due to potential game changes, the Minimum System Requirements for this game may change over time.

Recommended Compatible System Requirements
Operating System: Windows Vista, 7 or newer** (32bit/64bit)
Processor (CPU): Intel Pentium 4 - 2.0GHz or AMD equivalent (with SSE support)
System RAM Memory: 1.0GB (2.0GB recommended for Vista/7 and higher texture resolutions)
Graphics Card: Geforce® FX 5900 or newer, ATI Radeon™ 9600 or newer, with 128MB or better
Internet Connection: Broadband Internet Connection
DirectX Version: DirectX 9.0c
Disk Space: 11 to 15GB

** Note: With latest Service Packs and Updates.

HD (High Definition) Recommended System Requirements
Operating System: Vista or Windows 7 64bit with latest Service Packs and updates
Processor (CPU): Dual-Core Intel or AMD processor (Pentium D or newer; Athlon 64 X2 or newer)
System RAM Memory: 2.00 GB Minimum
Graphics Card: Nvidia Geforce 8600 or newer, ATI Radeon HD 2600 or newer; with 256MB or better
Internet Connection: Broadband Internet Connection
DirectX Version: DirectX 10 or 11
Disk Space: 15GB

Additional Notes: For installing via the DVDs you will need a 2X/4X speed DVD-Rom drive however please note that the DDO DVDs were released in 2006 and may no longer install a functional client. If the updated installation download is used this is much more pre-updated but will increase the needed disk space amounts noted above.

If you are running below any of these requirements, you may encounter graphical issues or poor overall gameplay performance which Turbine may be unable to troubleshoot.

Why is DirectX 9.0c required when I have DirectX 10 or 11, or I already have 9 installed?

The game requires specific files relating to DirectX 9.0c that may not be included with later versions of DirectX as each is a separate installation and has separate files. Additionally the game may also require specific customized versions of DirectX files that may not be included with your version of DirectX, and as such it may require these customized files are also installed in order to function correctly.

DirectX information can be found at support.microsoft.com and DirectX can also be updated via the site here as well.

Unsupported Operating Systems:

Currently DDO is not supported on the following operating systems or hardware:

  • Windows 98/98SE
  • Windows ME (Millennium Edition)
  • Windows 2000
  • Windows XP
  • Any "Beta" or "Preview" versions of Windows releases
  • Linux
  • PlayStation 2/3/4
  • Wii
  • Xbox/Xbox 360/Xbox One

If you need additional assistance, please contact SSG Technical Support.

Was this article helpful? 1 out of 2 found this helpful
Article is closed for comments.

Include search results from: You must select a search result group

Search results